GETTING STARTED IN PHASE II

Overview

This document provides a high-level description on how to get started (click here to see the movie) and submit a Phase II proposal using APT. APT provides a graphical and interactive means for developing a proposal. A familiarity with the basic APT interface is assumed (there have been no major changes from Phase I), so only Phase II specific items are discussed. Please be sure to read the Phase II Instructions, especially Chapter 2. To assist users in learning APT, short (typically 5 minutes) movies are available; see below for more details. Also, please check the APT FAQ & Bug List for more information, as well as the APT help menu.

Please contact your Program Coordinator (PC) for further assistance.

Screen Layout

The APT display window and basic capabilities are described in Introduction to the APT Interface.

Movies

APT is an interactive tool, so written documentation (with snapshots of the screen) is not the clearest way to explain how to use APT. We have therefore generated short (typically about 5 minute) movies, available via the Training Movies page on the following subjects:

Using Context Sensitive Help

Context Sensitive Help is available in APT for the Form Editor. To use this feature, click on any parameter in blue text, and the relevant sections of the Phase II Proposal Instructions will then be displayed in a pop-up Help window.

Other Help

APT-specific topics, such as how to create patterns, how to use orbit numbers and actual durations, and how to run the Orbit and Visit Planners, are accessible through the Help menu under the topic "APT Phase II Help". Also available are basic documentation such as the Phase II Proposal Instructions and the Instrument Handbooks.

Phase II Roadmap

To guide you through the Phase II preparation process, a Phase II Roadmap is available. The roadmap provides a step-by-step process for completing your Phase II proposal, with links to the appropriate documentation available for each step.

Diagnostics

Diagnostics are shown with either a (error) or a (warning). Errors are either missing information, incomplete or illegal information, or a problem reported by the Orbit or Visit Planner. There are four ways that diagnostics are reported in APT. Note that in the spreadsheets, red highlighting replaces the in marking incomplete or incorrectly specified values.

Saving Proposal Information

It is advisable to save your proposal (by selecting the Save or Save As option from the File menu) frequently to avoid any potential loss of data. Backup files are also generated each time you load or save the proposal. Note that results from running the Orbit Planner are stored both in the proposal file and in the same directory as the proposal file. Therefore, even though you have made no edits to the proposal, new information may be present which will cause APT to prompt you to save prior to exiting.

Step-by-Step Procedure

The APT is very flexible about the order in which you enter information. You can work on a proposal element (e.g., a target) by clicking on it in the Tree Editor and selecting a tool to operate on that element. Below is one process for creating a Phase II proposal.

  1. Start APT. APT operates in two modes: Phase I and Phase II. It will initially be in Phase I mode.
  2. Open your approved Phase I proposal in APT. The preferred method is to retrieve the proposal directly from STScI (under the File menu, select Retrieve from STScI and enter your Phase II proposal ID provided by your Program Coordinator). An alternate method is to locate the Phase I file you submitted, and read it into APT (under the File menu, select Open and browse to where your file is). Click on the Phase I -> Phase II button in the toolbar. You will be given an option to copy your Phase I fixed target coordinates into your Phase II proposal. The proposal will now appear in Phase II mode with Proposal Information and Targets containers partially populated from your Phase I, as well as empty Patterns and Visits containers.
  3. Start the Form Editor by clicking on this tool in the toolbar. Click on Proposal Information in the Tree Editor, and fill in the appropriate information (such as your assigned Phase II Proposal ID provided by your Program Coordinator, if you started with your own copy of your proposal). Note that the proposal level information has been carried over from your Phase I proposal. The Title should be left unchanged, while other fields such as Abstract can be edited.

    Those items marked with a in with the Form or Tree Editor are either incomplete or have incorrect values. A finished proposal should have no (and few, if any, ) present on any page or in the tree editor. The diagnostics may suggest what is missing, but more information can be obtained by using the context-sensitive help.

  4. Navigation. At the bottom of the form are buttons that can be used to navigate through the various proposal forms in a suggested order. The left arrow button goes to an earlier form, the New button allows for the creation of appropriate proposal elements, and the right button goes to the next form in the suggested sequence. Alternatively, the Tree Editor can be used to select any proposal element at any time.
  5. Proposal Description . Click on the navigation button below the form to go to the next form, the Proposal Description Form. Alternatively, click on the Proposal Description element in the Tree Editor. Fill in the requested information and click again on the navigation button to go to the PI and CoI forms. This information should be already filled in by APT (from your Phase I proposal). If you wish to make changes to the investigators, please contact your Program Coordinator.




  6. Target Form. Continue to the Target form by clicking on the Edit Targets button in the navigation bar. All targets in your Phase I proposal should appear in the Phase II proposal, and if you chose, the fixed target coordinates should appear as well. If additional targets are needed, add the desired target by clicking on the appropriate button in the toolbar. Click on the forward navigation button on the lower right of the form, and input the necessary information.
  7. For your fixed target coordinates, the field labeled "Position type" determines the subsequent fields that you will edit - Equatorial, Offset, or Region; the default value is Equatorial. If your coordinates were copied from your Phase I proposal, and the accuracy is not sufficient for Phase II purposes, you should update your coordinates. If you are using COS, then you must fill in the coordinate uncertainties.

    Also note that, as in Phase I, it is possible to import a comma-separated list of targets directly into APT; see How to ingest targets in Phase II for details.



  8. Patterns. After completing the target specification, you can create any pattern specifications that you may need in order to carry out your program. Go to Patterns by clicking on the Edit Patterns navigation button below the form, and click on New Pattern Specification. Select the pattern template desired, and change any default value that is not appropriate for your science. These templates will be referenced be exposures you create. See the Patterns document and movie for more information.
  9. Continue to the Visit form. Create a new visit, and fill out the appropriate information for the visit (i.e. the visit number and any visit-level special requirements). Note that all date fields take the format DD-MMM-YYYY (e.g. 01-Mar-2009) ; these are converted to GMT. Depending on screen size, it may be necessary to scroll left to see certain fields (e.g. units on AFTER VISIT).




  10. Continue to the Exposure form and provide the requested information there. Note that the Label field is optional, and is simply a text field to allow you to label exposures (e.g. you may wish to label the exposures in a Prime+Parallel Group with their instruments). This label will appear in the Tree Editor. You should also enter any optional parameters needed. There are no mandatory values (except for WFC3/IR MULTIACCUM observations), and all values left unset will use default values.

    The Adjusted Total Exposure Time tells you how much exposure time is represented by your exposure specification. For example, if the number of iterations is 2 and the exposure time is 1000s, then the adjusted total exposure time is 2000s.





  11. Exposure-level special requirements should be specified next. These are organized by category as in the Phase II Proposal Instructions. You should only enter values for those requirements that you wish to specify; those parameters left as "None Selected" will get the default values (documented in the Phase II Proposal Instructions).
  12. There is also a form for editing sub-exposures, but that step should be omitted at this point; see the Orbit Numbers document and movie for more information.

    In APT, grouped exposures (exposure sequences, coordinated parallels, and patterns) are placed in exposure containers, rather than being linked with a special requirement. Note that containers can be placed within containers (e.g. a coordinated parallel container in an exposure sequence).

  13. Exposure containers can be created, and exposures inserted into them.
  14. Create other exposures within the visit, as required, by clicking on the New Exposure button above the form. If other exposures (or exposure containers) are similar to an existing exposure, it may be expedient to duplicate the exposure by clicking on it in the Tree Editor and selecting Duplicate (or Multiple Duplicate) from the Edit menu. An alternate method for copying exposures is to use the Copy and Paste option in the Edit menu; see the movie on Editting with the Tree Editor .
  15. Orbit Planner . After all exposures are entered (or even after a subset of exposures are entered), run the Orbit Planner on your first visit. Pack the orbits to minimize unused orbital visibility. Note that you may want to edit the sub-exposure properties of actual duration and orbit number to do the packing (see next item below), or use the Auto-Adjust feature. See the Running the Orbit Planner document and movie , and the Auto Adjust document and movie for more information.




  16. Sub-exposures. To support the use of orbit numbers, and to allow for the manipulation of actual durations of pieces of exposures (e.g. a piece of a CR-SPLIT), each exposure has one or more sub-exposure elements. A sub-exposure may correspond to a single simple exposure, a piece of a CR-SPLIT exposure, each iteration of an exposure with multiple iterations, or an exposure at a pattern point. While each sub-exposure has the same basic properties of the parent exposure (e.g., detector, operating mode, etc.), it contains two properties that can be adjusted: the actual duration and the orbit number. These parameters (particularly the orbit number) may need to be edited when packing orbits. See the Orbit Number and Actual Durations document and movie for more information.
  17. Visit Planner. Now run the Visit Planner and adjust parameters to increase schedulability, if necessary. See the Visit Planner document and movie for more information.




  18. Save your work. Throughout the above process, it is advisable to save your proposal by clicking on Save (or Save As) in the File menu.
  19. View the proposal in PDF format by selecting the PDF Preview tool. See the documention on Understanding the Phase II PDF Proposal Preview .




  20. Create another visit if required, by clicking on Visits in the Tree Editor and then clicking on the New Visit button. Alternatively, if subsequent visits are similar to an existing visit, it may be expedient to copy/duplicate that visit by using the Copy/Duplicate menu item in the Edit menu. Note that it is possible to copy/duplicate multiple visits at a time (by clicking on the first visit in the Tree Editor, shift-clicking on the last visit, and the selecting Copy/Duplicate from the Edit menu).
  21. Process new visits. Once all the desired visits have been created, run the Orbit Planner and Visit Planner on them individually. Alternatively, select (using the shift-click) multiple consecutive visits or the entire proposal (by selecting the Visits container) in the Tree Editor and select the Run All tool. This tool may take a while to execute.
  22. Use the Aladin tool. Optionally, look at your exposures in the Aladin tool. See the Aladin help and movies for more information.
  23. Use Target Confirmation chart tool to verify the positions of your fixed targets. Note that if proper motion values have been supplied, the tools will take them into account. See the Target Confirmation chart document and movie for more information.
  24. Submission. The proposal can be submitted by doing the following:

If you have any questions about running APT, please contact your Program Coordinator.
Last modified: May 6, 2014.