INTRODUCTION TO THE APT INTERFACE

Overview

The APT user interface allows you to navigate through the various tools in APT, with the choice of tools dependent upon the mode (Phase I or Phase II) in which you are working; for a demonstration, see the training movie. You may work on one or more proposals during a session, although only one proposal may be active at a time. The APT user interface is composed of several different areas, each of which provides distinct capabilities. The different areas can usually be expanded or contracted by clicking on the area resizing triangles that appear in the area borders or by dragging the borders (see figure).





Definition of Interface Areas

There are six different areas to the APT interface:
  1. Menus - The uppermost portion of the interface consists of a series of menus (File, Edit, Tools, Current Tool, and Help) for file manipulation (e.g, saving the proposal), editing parts of a proposal (e.g., deleting observations), selecting a tool (e.g., the submission tool), selecting tool-specific tasks (e.g. update display), and help (e.g., access to the Call for Proposals). The Edit menu handles changes to proposal elements, but not the text within spreadsheets and forms (see Editors section below).
  2. Tool Bar - Just below the menus is a row of icons that can be selected to invoke the various tools (such as the Form Editor and the Submit tool) or operations (such as creating a new CoI). The tools can also be selected from the tools menu.




  3. Hierarchical (Tree) Editor - Along the left side of the user interface is a window which provides a view of the proposal similar to a tree format file browser used in graphical interfaces such as Solaris Desktop File Manager, Windows Explorer, and Mac Finder. Within this area you can view, create, delete, and copy elements of proposals (e.g., observations). Items listed in the Hierachical Editor that are incompletely or improperly specified are marked with a . You can expand the hierarchy by clicking on the key symbol just to the left of the element name (which will now point vertically). You specify the proposal element to be edited (in the Form or Spreadsheet Editors) by clicking on the element name (which then becomes highlighted). Some tools, such as the Spreadsheet Editors, allow more than one proposal element to be selected for editing. This selection is accomplished by holding down the Control key and clicking on desired items. Contiguous items can be selected by clicking on the first item and then by holding down the Shift key and clicking on last item; see the movie on GUI editting tips for more on using the Tree Editor.
  4. Mini-Spreadsheet - Along the bottom of the interface is an editor which displays the details of the proposal element selected for editing in the Hierarchical Editor. It provides a convenient means for editing properties of proposal elements while the output of another tool is visible. For example, you can edit an exposure time in the Mini-Spreadsheet while the Orbit Planner output is visible. This tool may not be visible to you when you start the APT and can be made visible by dragging the bottom border of the tool display area upwards. The information in the Mini-Spreadsheet can generally be edited directly by clicking on the desired field, although in some cases a window will pop up to allow entry of information (e.g., if the field can contain a large amount of text, such as the abstract). The Mini-Spreadsheet marks improper items by red highlighting. Note that you can change the order of the columns by placing the cursor on the column title and dragging the entry, and the size of the columns by placing the cursor on the right-hand boundary and dragging. A single click on the column title will enable a sort mode for the column; subsequent clicks will sort in ascending and descending order.
  5. Display Area - The central region of the interface is the display area for the currently selected tool, the "Tool Display" in the above figure. When a tool is selected, it operates on the element chosen in the Hierarchical Editor/Mini-Spreadsheet. The Form Editor and Spreadsheet tools play a special role in that they each allow for editing any portion of a proposal, apart from the Phase I attachment. If no tool is selected, the Form Editor will appear by default in the tool area when you select an item in the Hierarchical Editor.
  6. Diagnostics Area - The lower right of the interface displays the number of current errors and warnings. By clicking on this region, you will get the Diagnostics Browser, which provides a detailed description of all diagnostics in the proposal.

Navigation

To operate on a proposal item, you need to select the item from the Hierarchical Editor and select a tool to carry out the operation. For example, if you want to view an element of a proposal (e.g., a Phase I observation) in the Form Editor, you should click on that element in the Hierarchical Editor and click on the Form Editor in the Tool Bar. The tools can generally be run in any order (e.g., you can edit the observations of a Phase I proposal before you fill in the Proposal Information).

The bottom of the Form Editor display contains a navigation feature which suggests possible steps that a user may want to carry out next. The right arrow suggests a further step, the left arrow suggests a prior step, and the triangle in the middle suggests the creation of a new proposal item. All three are active buttons.

Editors

There are two main editors for the contents of a proposal: the Form Editor and the Spreadsheet Editor. (The Hierachical Editor is mainly used for selecting objects and viewing the overall structure of the proposal.) The Form Editor provides a vertical listing of the information and marks incompletely or erroneously specified information with a . The Spreadsheet Editor provides a horizontal listing of the information and marks improper items by red highlighting. It has the capabilities of the Mini-Spreadsheet described above for rearranging and sorting columns. The APT editors check for syntax and correctness when you enter values, and they limit selection lists to values that are consistent with other entries (e.g., if you specific WFC3 as your instrument, you can only select WFC3 filters).

You can cut, copy, etc. proposal elements that appear in the Hierarchical Editor (i.e., complete proposals, CoIs, and Exposures) through the Edit menu. You can also cut, copy, etc. text involving the spreadsheets or forms through the Edit menu. Whether the Edit menu operates on proposal elements in the Hierarchical Editor or text in the Form and Spreadsheet Editors is determined by the region that was last used (i.e., had last focus).

Alternatively, you can use control keys to cut, copy, and paste items in the Hierarchical Editor and text in the Form and Spreadsheet Editos. Again, the affected area (tool area or Hierarchical Editor) is the one that was last used (i.e., the area that has focus). The control keys for cut, copy, and paste are Control-x, Control-c, and Control-v, respectively for Linux, and Windows; and Command-x, Command-c, or Command-v, respectively for Macintosh. In the case of Solaris, to cut, copy, or paste text, you should use the appropriate cut, copy, or paste keys on the Sun keypad.

Displaying/Printing

In Phase I, the PDF Preview tool displays the complete proposal (information inputted to APT merged with the PDF attachment), which is what the TAC will use for evaluating the proposal. The PDF Preview display can be printed through the PDF viewer (the PDF previewer saves the file as postscript) or saved as a PDF file through the Export menu item in the File menu. In Phase II, the PDF version shows the complete proposal, by visit, along with the Orbit Planner output; the Visit Planner tool provide capabilities for printing its tool results.

Help

There are several types of help available in APT.