PHASE I GETTING STARTED IN APT

Overview

This document provides a high-level description on how to get started and submit a Phase I proposal using APT; for a demonstration using specific examples, see the training movie. APT provides a graphical and interactive means for developing a proposal. To assist users in learning APT, short (typically about 5 minutes) movies are available; see below for more details. Also, please check the APT FAQ & Bug List for more information, as well as the APT help menu.

Screen Layout

The APT display window and basic capabilities are described in Introduction to the APT Interface.

Phase I Roadmap

To guide you through the Phase I preparation process, a Phase I Roadmap is available. The roadmap provides a complete step-by-step process for completing your Phase I proposal, with links to the appropriate documentation available for each step.

Movies

APT is an interactive tool, so written documentation (even with snapshots of the screen) is not necessarily the clearest way to explain how to use APT. We have therefore generated short (typically about 5 minute) movies which are offered (usually with text equivalent) throughout the APT on-line documentation. These movies are highly recommended by those who have used them.

Using Context Sensitive Help

Context Sensitive Help is available in APT for the Form Editor. To use this feature, put your cursor on the parameter of interest. If that parameter is blue, you will see the cursor change to . If you then click on the parameter, the relevant sections of the Call for Proposals/Primer will then be displayed in a pop-up Help window.

Other Help

APT-specific topics, such as how to Analyze Scheduling Contraints with APT and how to ingest fixed targets are accessible through the Help menu under the topic "Phase I Specific APT Training Materials". Also available are basic documentation such as the Call for Proposals, Primer, and the Instrument Handbooks.

Diagnostics

Diagnostics are shown with either a (error) or a (warning); see the separate movie or document . Errors are either missing information, incomplete or illegal information, or a problem reported by the Visit Planner. There are four ways that diagnostics are reported in APT. Note that in the spreadsheets, red highlighting is used to mark incomplete or incorrectly specified values.

Navigation

At the bottom of the display are buttons that can be used to navigate through the various proposal forms in a linear order. The left arrow button goes to an earlier form, the New button allows for the creation of appropriate proposal elements, and the right button goes to the next form in the suggested sequence. Alternatively, the Tree Editor can be used to select any proposal element at any time.

Saving Proposal Information

It is advisable to save your proposal (by selecting the Save or Save As option from the File menu) frequently to avoid any potential loss of data. Backup files are also generated each time you load or save the proposal.

Reading in a previous cycle's proposal

When you read in a previous cycle's proposal, you will immediately get some error conditions (such as the cycle number being incorrect for the present deadline) which will need to be corrected. Also, APT will attempt to check the addresses of all investigators with the STScI address database to get the most up-to-date address information. Those investigators with information in the proposal that differs from the database, or who could not be matched, will need to be checked.

Step-by-Step APT Procedure

The APT is very flexible about the order in which you enter information. You can work on a proposal element (e.g., a target) by clicking on it in the Tree Editor and selecting a tool to operate on that element. Below is one process for creating a Phase I proposal.

  1. Start APT. APT operates in two modes: Phase I and Phase II. It will initially be in Phase I mode.
  2. Open a new proposal in APT by going to the New Document pulldown and selecting New HST Proposal. Alternately, you can read in a previous cycle's proposal or one that you previously started (under the File menu, select Open and nagivate to where the file is).
  3. Start the Form Editor by clicking on this tool in the tool-bar; if you opened a New HST Proposal, you will be in the Form Editor by default. Click on Proposal Information in the Tree Editor, and fill in the appropriate information.

    Those items marked with a in the Form or Tree Editor are either incomplete or have incorrect values. A finished proposal should have no errors (and few, if any, warnings) present on any page or in the tree editor. The diagnostics may suggest what is missing, but more information can be obtained by using the context-sensitive help.



    The information about your allocation request varies depending upon the type of proposal (GO, SNAP, or AR) you are submitting. GO programs request orbits (for up to 3 cycles), SNAP programs request targets, and AR programs request dollars.



  4. Fill in PI and Co-I information. Click on the navigation button below the form to go to the next form, the Principal Investigator Form. Alternatively, click on the PI element in the Tree Editor. If you are on-line, enter your last name (or the first few characters of your last name) and either tab or hit return. APT will do an address lookup from the STScI address database. If you locate your name, select your record in the Lookup window and hit Select, which will populate the required address fields. If you are unable to find your information then hit Add New Address button, which will take you to the ProPer tool so that you can add the new person to the database. If you are in the database, but the address information is wrong, then click on the Update This Address button, which will again take you to ProPer so you can update the information. See the address FAQ for more information.








  5. Navigate to the Co-I page and enter your Co-I information. Use the New pulldown under the toolbar to add more Co-Is. To delete an unused Co-I template, select the item in the Tree Editor, go to the File menu, and select Delete.
  6. Enter your target information. Select the Targets folder in the Tree Editor, and click on the type of target you wish to enter ( Fixed, Solar System, or Generic). Fill in the appropriate information. Note that there is a Target Resolver available, and that you can import a comma-separated list of fixed targets directly into APT; see How to ingest fixed targets in Phase I for details.







    If additional targets are needed, add the desired target by selecting the appropriate type under the New pulldown in the tool-bar. Click on the forward navigation button on the lower right of the form, and input the necessary information.

  7. Enter your Observations. Select the Observations folder, and click on the New Observation button to display an Observation template. Fill in the required information.



    Note that the Instrument Setup area does not become active until you have selected your Instrument.



    When you hit Add, you will get a pop-up that will allow you to enter the instrument setup information. Continue to add instrument setups until the observation for the target is complete. Enter any scheduling constraints (check the No Scheduling Contraints box if you have none) for the observation. The addition of scheduling contraints can severely limit the number of days your observation can execute. Please see the separate document on How to Analyze Scheduling Constraints with APT. Continue adding more Observations until your proposal is complete.
  8. Reviewing your Observations in Aladin (optional). If you want to visualize your Observations in Aladin (see the Using Aladin with APT in Phase I document and movie for more information), then complete the Aladin parameters sections at the bottom of the Observation form.



  9. Run the Visit Planner on fixed target observations. Now run the Visit Planner and adjust parameters to increase schedulability, if necessary. This step is particular important for Large programs, or those with tight scheduling constraints. See the How to Analyze Scheduling Constraints with APT document and movie for more information.




  10. Save your work. Throughout the above process, it is advisable to save your proposal by clicking on Save (or Save As) in the File menu.
  11. View the proposal in PDF format by selecting the PDF Preview tool. This view is what the TAC will be seeing when they discuss your program, so please review it carefully.
  12. Submit the proposal by selecting the Submission tool. Type in any comments that you have, and click on the Submit Phase I button. In the Submission Log window you will see a message giving the time of the submission, the assigned proposal ID (if a new proposal), and the submission status. The PI and all CoIs will receive an automatic email acknowledgment that the merged PDF submission was received successfully.

    After the Phase I deadline has passed, and all submissions are in their final form, you will receive final notification that your submission has been successfully processed; this email will mark the completion of the submission. If you do not receive an acknowledgement within 48 hours of the deadline, please contact the STScI Help Desk as your submission was NOT RECEIVED and the Telescope Allocation Committee WILL NOT see your proposal; please provide the submission ID information from the APT Submission Log window. If there are any problems associated with your PDF attachment, you will be contacted by email separately.




If you have any questions about running APT, please contact help@stsci.edu.
Last modified: February 7, 2014.