Topic PG Action Who - [+] 1 Take out Object Type 5 ACTION Pat - [+] 2 ReadoutRegion should be subarray - globally 5 ACTION Pat - [+] 3 Consider removing DItherType 5 DISCUSS Pat Decided to leave it in - [+] 4 Crossed filters should all have + not _ 6 ACTION Pat - [+] 5 Order of Pupils could be made to match java code 7 ACTION Pat - [+] 6 Object Type removal again 9 ACTION Pat - [+] 7 CoronMask should be closer to the GUI name? CoronagraphicMask 9 REJECT Pat - [+] 8 Filters should be ExposureSpecificationList - Configs should be 9 PR 61807 Pat ExposureSpecification - [+] 9 Karla pointed out that the xml should most closely match the GUI 9 PR 62029 Pat and Propinst names, and not the OPGS names, since the user will be more likely to see them - [+] 10 How should we spell the instrument name of nircam? They should 11 REJECT Pat be consistent. - [+] 11 ReadoutRegion = Subarray 11 ACTION Pat - [+] 12 Exposures should be ExposureSpecificationList - Configs should be 11 PR 61807 Pat ExposureSpecification - [+] 13 Groups and Integrations - we should be consistent w/ regard to 12 ACTION Pat using Number or not - [+] Decided to remove Number from all - [+] 14 LinearActuatorType is not actually the same type for Position, 12 PR 62029 Pat Sensor, and Phase - [+] 15 Positions should be PositionList 12 PR 61807 Pat - [+] 16 Position should not have maxOccurs=10 12 ACTION Pat - [+] 17 as above items 1,2 re: filters, dithers, objecttype 13 ACTION/DISCUSS Pat - [+] 18 Same issues regarding how consistent names should be between 14 DISCUSS Pat schema and DM Decided to let it be as is. Developers have different styles. - [+] 19 Exposures means number of Exposures - don't need the "number"? 14 REJECT Pat - [+] 20 Why showing num Exps twice? 14 ACTION Pat - [+] 21 Number of Rotations or Rotations? 15 ACTION Pat - [+] Used Rotations. - [+] 22 JwstFilter should be an interface if it is going to be used for 19 ACTION Rob sharing Target Acqs - [+] 23 enums should all be static - style-wise 20 ACTION Rob - [+] 24 if wavelength == null, return all 23 REJECT Rob * [+] 25 can register filters with Wavelegth when adding them in the 23 ACTION Rob constructor - then statically access list - [+] 26 same for Pupil 23 ACTION Rob - [+] 27 can use foreach instead of for i, but that will be moot.... 23 REJECT Rob - [+] 28 inline comments would be useful here 23 REJECT Rob - [+] 29 make Round and Bar enums... 25 ACTION Rob * [+] 30 What is going on with camera vs Wavelength in the NirCamMask 25 ACTION Rob - [+] 31 NirCamMask - name should be NirCamCoronMask 25 ACTION Rob - [+] 32 could we put an EnumMap in place to register factories for 29 ACTION Rob instruments - [+] 33 is it ok that our code is assuming all instruments are singletons? 29 DISCUSS Rob We think it is ok - [+] 34 remove Flat_Suite 30 ACTION Rob - [+] 35 remove Wavelength 30 ACTION Rob - [+] 36 rename MASK to CORON_MASK 30 ACTION Rob - [+] 37 remove OBJECT_TYPE 30 ACTION Rob - [+] 38 remove CORON_FILTER 30 ACTION Rob - [+] 39 is there a way to generify the returns of the ExposureSpecTables? 31 DISCUSS - ANDY Rob Implemented with PR 61457 * [+] 40 remove useless /*..*/ comments with nothing in them 34 ACTION Rob - [+] 41 should we use statics for Min and Max values for motor phase, 35 ACTION Rob wheel, and rotations? - [+] 42 use null for unbounded Max values 35 ACTION Rob - [+] Did NirCam - [+] Need to do MIRI too DISCUSS - [+] 43 Code block in initializer - Tom objects to the code 36 REJECT Rob - [+] 44 Remove TODOs that we don't want to actually do something..... 38 ACTION Rob * [+] 45 Want to use a clearer implementation for the Table interface 40 PR Rob instead of the abstract PR 61457 - [+] 46 Miri still in comments in many files..... ACTION Rob * [+] 47 Can I ask isLegal of all fields to implement this? 42 ACTION Rob * [+] 48 All these lists of fields are all an issue - can we make an 45 PR/DISCUSS Rob array? Same note There is a PR for this for MIRI - we can try to do this for the new Instruments first. We decided it was a god idea to try to do this for new instruments. - [+] 49 we could have a CosiDerivedPropertyField, so I don't need to 46 PR 62032 Rob carry both.... - [+] 50 should we override getParent to return the correct type? 49 DISCUSS Rob No - we made it so that the template is passed in to the constructor - [+] 51 Comment that we assume getTemplate is only called when there is a 49 DISCUSS Rob Parent No longer an issue - [+] 52 number of groups should be allowed to be specified 50 ACTION Rob - [+] 53 there is a cosi constraint messing up the acqFlux field - not 51 ACTION Rob really, this was actually just a bad method name. - [+] 54 mask should use coron in its name 53 ACTION Rob * [+] 55 how are templateProperties and Properties related? DISCUSS/ACTION Rob - [+] 56 add ability to disable Add button when 6 rows made....(new PR?) 57 PR 62031 Rob - [+] 57 Should we add some kind of diagnostic ID to our cosi checks for 57 PR 61782 Rob diags File a PR - [+] 58 get rid of commented out filter legals 58 ACTION Rob - [+] 59 should readoutpattern and numgroups be uneditable - or even 58 ACTION Rob defaulted? - no, this was wrong. - [+] 59.1 Don't think they should - [+] 60 setFilter could be done wrong if called before setMask.... 58 ACTION Rob - [+] No it won't the Cosi will protect against that - [+] 61 deafult should throw an exception - check other places as well 59 ACTION Rob - [+] 62 consider getting rid of BOTH on the wavelength - use an EnumSet 59 ACTION Rob for the constructor - [+] 63 Miri Field factory is being used to get NirCam num exps 64 ACTION Rob - [+] 64 Should Flat be InternalFlat? 66 REJECT Rob - [+] 65 and other places - Invalid Parameter should be Illegal Argument 68 ACTION Rob exceptions - [+] 66 using miri again 69 ACTION Rob - [+] 67 verify that readout patt and groups are defaulted - should be 70 ACTION Rob uneditable - [+] 68 find table of valid exp times from propinst and implement those 70 DEFER Rob - [+] 69 Wheels not supposed to be plural in this diag message 72 ACTION Rob - [+] 70 Does this diag work - or create 2 of them? Works 72 NO ACTION Rob - [+] 71 move statics to instrument class, and pass only a number to the 73 ACTION Rob makes.... - [+] 72 change comment from wheels to mechanism 73 ACTION Rob - [+] 73 order Filters to be in alphanumeric order 73 ACTION Rob - [+] Code change - [+] PR to change PROPINST as well - PR 61786 - [+] 74 share this table in one place - NirCam Instr - so Focus and Flat 73 ACTION Rob use it - [+] 75 FILE PR on PROPINST to order Filters in chapter 14 as well: 73 ACTION Rob covered under PR 61786 - [+] 76 Should Linear Actuator ID be an enum instead of an int? 77 REJECT Rob - [+] 77 Remove the Be Advised comment in all tables 80 ACTION Rob - [+] 78 Why are we blocking null and "" from the setValueAt() method 80 ACTION Rob - [+] This applies retroactively to all Exp Tables... - [+] 79 We are not populating the data in the LA Table because we don't 83 PR 61768 Pat understand the schema - [+] 80 Why are we using WAVELEN? 127 REJECT Pat - [+] 81 NUM_INT and NUM_INTS not both needed 127 Pat - [+] 82 mask should be coron? 127 ACTION Pat - [+] make it coronmask - [+] 83 enum should be static 127 REJECT Pat - [+] 84 enum needs to be updated when DB is updated - yeah, so? 127 REJECT Pat - [+] 85 exposing implementation with a Vector return type instead 128 REJECT Pat - [+] 86 Can we delete just a Proposal and have all the others delete 128 REJECT Pat (Cascade) Asked about this in DB Meeting - bad idea since some relations to proposal may not be APT related. Plan Windows should not be deleted as part of an update, for instance. Better that APT delete what it knows it is responsible for. - [+] 87 MIRI Low Resolutin Spectroscopy spelled wrong 128 ACTION Pat - [+] 88 Should we have a separate name in APT and the SQL? 128 REJECT Pat Decided to keep the design as is - [+] 89 make fFile and fProp final and provide at construction only 128 ACTION Pat - [+] 90 throw NPE if null is sent to constructor 128 REJECT Pat - [+] 91 Don't need to drill down through hierarchy to get all the Obs and 128 ACTION Pat Vis - [+] 92 and you can use addAll(fProp.getChildren())) to add them all in 1 128 ACTION Pat step - [+] 93 make sure File exists and is writeable, etc. 130 PR 62033 Pat - [+] 94 again, don't need Targets object to get Children 131 ACTION Pat - [+] 95 comment about undefined fields may be irrelevant, or need updating 132 REJECT Pat - [+] 96 can we get rid of all the ifs and instanceof checks by subclassing 132 PR 62034 Pat - [+] 97 do we want to rename MiriSpectralElements record? 132 PR 62030 Pat - [+] 98 if using index more than once, don't do index++ until the end 132 ACTION Pat - [+] 99 could use the superclass MiriSpectroscopicTemplate for MRS and LRS 133 PR 62034 Pat - [+] 100 all the ifs are exclusive - so if you have a subclass later on, 133 PR 62034 Pat it will pass the first test and not go on - [+] 101 _A shouldn't be there - there should only be a shortFilter 135 PR 61489 Pat longFilter, etc. - [+] 102 should we steal String sanitization code for special chars from 138 PR 62035 Pat HST? - [+] 103 should we be protecting against malicious SQL in things like 138 PR 62035 Pat Abstract.... File a PR and prioritize - [+] 104 would we ever want to use these datastructures for change 138 DISCUSS ` checking? Make a note in Design document under change checking - [+] 105 in general - I think use STATIC strings instead of literals in 138 ACTION Pat the code - [+] 106 Why ordered the way they are? No reason 140 REJECT Pat - [+] 107 all these can be static classes - they don't care about the 140 PR 62036 Pat SQLExporter - [+] 108 back on NirCam Focus - Return to Start should be defaulted to ACTION Rob Yes (True) - [+] 109 bulb doesn't exist anymore 141 ACTION Pat - [+] 110 only one of detectors and modules 141 PR 61489 Pat - [+] 111 why default type to F for target? Can get the real value 143 PR 62037 Pat - [+] 112 Can get position Reference from target for real too 144 PR 62037 Pat